Wednesday, September 29, 2010

network

How to remove IP address from a NIC
no comments
by admin in AIX

How to remove IP address from a NIC

root [AIXServer] /: chdev -l en1 -a state=down
en1 changed

root [AIXServer] /: chdev -l en1 -a netaddr=''
en1 changed
root [AIXServer] /: chdev -l en1 -a netmask=''
en1 changed

root [AIXServer] /: lsattr -El en1
alias4 IPv4 Alias including Subnet Mask True
alias6 IPv6 Alias including Prefix Length True
arp on Address Resolution Protocol (ARP) True
authority Authorized Users True
broadcast Broadcast Address True
mtu 1500 Maximum IP Packet Size for This Device True
netaddr Internet Address True
netaddr6 IPv6 Internet Address True
netmask Subnet Mask True
prefixlen Prefix Length for IPv6 Internet Address True
remmtu 576 Maximum IP Packet Size for REMOTE Networks True
rfc1323 Enable/Disable TCP RFC 1323 Window Scaling True
security none Security Level True
state down Current Interface Status True
tcp_mssdflt Set TCP Maximum Segment Size True
tcp_nodelay Enable/Disable TCP_NODELAY Option True
tcp_recvspace Set Socket Buffer Space for Receiving True
tcp_sendspace Set Socket Buffer Space for Sending True
root [AIXServer] /:

tags: IP address, NIC, Remove
No comment?
September 17, 2010 11:33 pm
Add a route with a specific mtu value
no comments
by admin in AIX

Technote (FAQ)

This document applies only to the following language version(s):

US English
Question

How do you add a route with a specific mtu value when it is different than the interfaces default mtu value?
Answer

To add a route with a different mtu value other than interfaces default mtu value you will need to run the "route add" command. You can not add the route via smit or smitty.

Add a network specific route with mtu of 1500.
#route add -net -mtu 1500

Example: Add route to 192.18.5.0 network using gateway address of 192.19.88.1 with an mtu of 1500.
#route add 192.18.5.0 192.19.88.1 -mtu 1500

Add a host specific route with mtu of 1500.
#route add -host -mtu 1500

Example: Add a route to 10.55.44.22 host using the gateway of 192.88.5.1 with the mtu of 1500.
#route add -host 10.55.44.22 192.88.5.1 -mtu 1500

To display newly added route:

#pmtu display

Example:
dst gw If pmtu refcnt redisc_t exp
192.18.5.0 192.19.88.1 en0 1500
10.55.44.22 192.88.5.1 en1 1500

tags: route, specifi MTU
No comment?
11:33 pm
Verify MTU value of route.
no comments
by admin in AIX

Technote (FAQ)

This document applies only to the following language version(s):

US English
Question

How do you verify a route is using an MTU value of 1500 versus 9000 (jumbo frames)?
Answer

To verify that the route is using an MTU of 1500 instead 9000 (jumbo frames) run iptrace and capture the 3-way handshake of a connection. Look at the MSS value. If the MSS is lower than 1500 then it isn't using jumbo frames.


1. Start iptrace:
#startsrc -s iptrace -a "-a -d /tmp/filename.ipt"

2. Use telnet or ssh to connect to the ip address of the route that you are trying to verify mtu value of.

3. Stop the iptrace:
#stopsrc -s iptrace

Run ipreport on the binary output file:

#ipreport -rnsC /tmp/filename.ipt > /tmp/filename.ipt.txt

Use vi to view the text output file. Search for SYN/ACK packet in the 3 way handshake.

Example of output:
Packet Number 2
ETH: ====( 74 bytes received on interface en3 )==== 14:59:21.176136222
ETH: [ 00:01:e8:53:47:1c -> 00:1a:64:fb:3f:60 ] type 800 (IP)
IP: < SRC = 10.199.172.200 >
IP: < DST = 192.58.3.186 >
IP: ip_v=4, ip_hl=20, ip_tos=0, ip_len=60, ip_id=0, ip_off=0 DF
IP: ip_ttl=63, ip_sum=c038 (valid), ip_p = 6 (TCP)
TCP:
TCP: th_seq=4187237060, th_ack=2426507443
TCP: th_off=10, flags
TCP: th_win=5792, th_sum=df6 (valid), th_urp=0
TCP: mss 1460
TCP: nop
TCP: nop
TCP: timestamps TSVal: 0x1479d1e6 TSEcho: 0x4cdba034
TCP: nop
TCP: wscale 7

The mss is 1460 so it is indeed using the mtu value of 1500 and not using an mtu of 9000 (jumbo frames).

No comments:

Post a Comment