Wednesday, September 29, 2010

How to reduce the /var or /tmp filesystem

The following steps reduce the size of the /var or /tmp file system in all supported releases of AIX Versions 4 and 5. If either file system on your machine is 8192KB in size or smaller, you probably should not reduce it. The default size of the /var file system (on installation) is 4096KB, which fills up rather quickly. If you can afford the space, it is better to have /var be 8192KB total. The default size of the /tmp file system (upon installation) is 8192KB.

NOTE: Back up the data before proceeding. If you have a tape drive connected to your system, this can be achieved by executing the following sequence of commands on either /var or /tmp:

cd /
tar -cvf /dev/rmt0 /var

/dev/rmt0 can be replaced with /dev/fd0 or the full path of a directory NOT in the same file system.


Boot your system into a limited function maintenance shell (Service or Maintenance mode) from bootable AIX media.

Please refer to your system's user's or installation and service guide for specific IPL procedures related to the type and model of your system. Additionally, the document titled "Booting in Service Mode", has specific procedures for most types of systems. The document is available at this location:

http://techsupport.services.ibm.com/rs6k/techbrowse


With bootable media of the same version and level as the system, boot the system into Service mode.
The bootable media can be any ONE of the following:

Bootable CD-ROM
NON_AUTOINSTALL, bootable mksysb
Bootable Install Tape
Follow the screen prompts or icons to the Welcome to Base OS menu.


Choose Start Maintenance Mode for System Recovery (Option 3). The next screen displays prompts for the Maintenance menu.

Choose Access a Root Volume Group (Option 1).
The next screen displays a warning that indicates you will not be able to return to the Base OS menu without rebooting.


Choose 0 continue.
The next screen displays information about all volume groups on the system.


Select the root volume group by number. The logical volumes in rootvg will be displayed with two options.

Choose Access this volume group and start a shell. (Option 1).
If you get errors from the preceding option, do not continue with this procedure. Correct the problem causing the error. If you need assistance correcting the problem causing the error, contact one of the following:

Local branch office
Your point of sale
Your AIX support center
If no errors occur, proceed with the following steps.


Unmount the file system. (The following examples use /var. If you intend to reduce the /tmp file system, substitute /tmp for /var in the commands.) Execute:
umount /var

Remove the file system by executing:
rmfs /var


Determine the physical partition (PP) size of your rootvg volume group with the command:
lsvg rootvg

Create the logical volume with one of these commands:
mklv -y hd9var rootvg [x] (for /var)
mklv -y hd3 rootvg [x] (for /tmp)

where x is the number of logical partitions you want to allocate. If your rootvg volume group has a PP size of 4MB, and you want the total size of the /var file system to be 8MB, then x would be 2. For example:

mklv -y hd9var rootvg 2

This command makes a logical volume hd9var of size 8MB (two 4MB partitions) in the rootvg volume group.

NOTE:The logical volume name used for the /tmp file system is hd3, and hd9var is the logical volume name used for /var. These names must be used if you wish to maintain your AIX system in an IBM supported state.


Create the file system with the following command:
crfs -v jfs -d hd9var -m /var -a check=false -a free=false -a vol=/var


NOTE: Substitute hd3 for hd9var and /tmp for /var if needed. Refer to the section Example of /etc/filesystems for the different attributes required for these filesystems.


Mount the file system:
mount /var (OR mount /tmp)

If you are recreating /var, now create the /var/tmp directory for the vi editor. Execute:
mkdir /var/tmp

Set your TERM variable and export it. If you are using a megapel display, try setting TERM=hft. If you are using an ASCII terminal such as an IBM 3151, set your TERM to the appropriate terminal type. For example:
TERM=hft
export TERM

Edit /etc/filesystems. If you have been recreating /tmp, invoke the vi editor by executing the following command:
vi -c "set dir=/" /etc/filesystems

If you have not been recreating /tmp, execute:

vi /etc/filesystems

Skip down to the stanza for either /var or /tmp. Within that stanza, go to the line that says mount = false and change the word false to automatic. Save the file.


Change the ownership and permissions to the proper values, as follows:
chmod g-s /var
chmod 755 /var
chown bin.bin /var

or

chmod g-s /tmp
chmod 1777 /tmp
chown bin.bin /tmp

Restore the files from your backup. If you used the backup method given earlier in this document, execute:
cd /
tar -xvf /dev/rmt0

Remove the bootable media if you have not already done so.

If your system has a mode select key, switch it to the Normal position.

Reboot the system into Normal mode with the following:
sync;sync;sync;reboot

No comments:

Post a Comment